Create your own Interactive Fiction

ADRIFT - Interactive Fiction  
Home   |   News ADRIFT News RSS   |   Screenshots   |   Download   |   Games ADRIFT Reviews RSS   |   Forum   |   Help   |   Links
Welcome Guest Register | Login
Popular Games
Skybreak! v. 1.1
Top Hat
The Axe of Kolt
The PK Girl
Museum Heist
Tribute: Return to the City of Secrets
Magnetic Moon
The Lost Labyrinth of Lazaitch
The Spectre of Castle Coris
the virtual human
 
Latest Forum Posts
How's the apocalypse treating you all?
New Record
Vee Station
Grandpa Rules (working title)
climb character?
Climb Tree
Greeting character
Static object inside a container?
Overriding default text on new tasks
Museum Heist
 
Latest Reviews
Museum Heist
The Spectre of Castle Coris
The Axe of Kolt
Die Feuerfaust
Penrhyn - Burning Skies #GameJam420
Dreamspun #GameJam420
Tingalan
Skybreak! v. 1.1
The Lost Labyrinth of Lazaitch
Revenge of the Space Pirates

Make a donation

Get it from CNET Download.com!
Cursor  Old games load new libraries

Issue Type: Status: Priority: Date Submitted: Votes:
Bug Completed Medium Tue 8th Apr 2014 2 votes Vote Up Vote Down
 
Found in version: Last Updated: Completed in version: Date Completed: Track Changes:
5.0.31.4 Tue 18th Nov 2014 5.0.33 Tue 18th Nov 2014 Log In
 
saabieTue 8th Apr 2014 07:24
If I try to play a game from an earlier version of ADRIFT in the runner, all of my libraries are being loaded and merged with the game automatically so that it is no longer playable.
I have to start the developer and disable all of my libraries leaving only the standard library before I start the runner and load the game.
Then I have to remember to go back and enable them all again before I work on my own games.

There is absolutely no reason why the runner should be looking at the developer settings at all.
ADRIFT 5 games contain all the libraries they need within themselves.
Older ADRIFT games require the specific library that was written to provide compatability with those old games.
The Runner should know the name of the library that it needs to load to run these games, and should only ever load that library.
 
CampbellTue 18th Nov 2014 20:28
Fixed.
© 2013 Campbell Wild. All rights reserved. | Contact the Webmaster