Create your own Interactive Fiction

ADRIFT - Interactive Fiction  
Home   |   News ADRIFT News RSS   |   Screenshots   |   Download   |   Games ADRIFT Reviews RSS   |   Forum   |   Help   |   Links
Welcome Guest Register | Login
Popular Games
Skybreak v 1.2
The Fortress of Fear
Combined Library Release 3.0 (taf- & amf-file + readme)
The PK Girl
The Dragon Diamond
Jacaranda Jim
the virtual human
Die Feuerfaust - The Fist of Fire
Magnetic Moon
Starship Quest
 
Latest Forum Posts
ParserComp 2021: Voting period extended to include this weekend
Fake ending module
Overriding the UNDO command?
Hiding location on map?
"Held By Character" Error
Compatibility list for Frankendrift
Frankendrift - early stages of Mac & Linux Runner
So....the site?
Most locations in Interactive Fiction
TESTING TESTING
 
Latest Reviews
Alien Diver v15
The Axe of Kolt
The Lost Children
Illumina
The Garden Party
A Difficult Puzzle
Regrets
A Party to Murder
Skybreak v 1.2
P/o Prune's mini comp.

Make a donation

Cursor  Old games load new libraries

Issue Type: Status: Priority: Date Submitted: Votes:
Bug Completed Medium Tue 8th Apr 2014 2 votes Vote Up Vote Down
 
Found in version: Last Updated: Completed in version: Date Completed: Track Changes:
5.0.31.4 Tue 18th Nov 2014 5.0.33 Tue 18th Nov 2014 Log In
 
saabieTue 8th Apr 2014 07:24
If I try to play a game from an earlier version of ADRIFT in the runner, all of my libraries are being loaded and merged with the game automatically so that it is no longer playable.
I have to start the developer and disable all of my libraries leaving only the standard library before I start the runner and load the game.
Then I have to remember to go back and enable them all again before I work on my own games.

There is absolutely no reason why the runner should be looking at the developer settings at all.
ADRIFT 5 games contain all the libraries they need within themselves.
Older ADRIFT games require the specific library that was written to provide compatability with those old games.
The Runner should know the name of the library that it needs to load to run these games, and should only ever load that library.
 
CampbellTue 18th Nov 2014 20:28
Fixed.
© 2013 Campbell Wild. All rights reserved. | Contact the Webmaster